Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

Mobilt bredband på Linux: "Upprop"!

Jag har uppdaterat Wiki-sidan om 3G med information från operatörerna. Jag skulle gärna se att så många som möjligt testar uppgifterna och hör av sig om något inte fungerar.

I dessa dagar när mobilt bredband verkligen blivit populärt så tycker åtminstone jag att det är viktigt att man kan få igång det på sin Linux-dator. Framförallt skulle det behövas mer information om själva modemen. Det vanligaste är väl kanske den sk "dongle:n" (Huawei E220), och den fungerar så vitt jag vet riktigt bra under Linux. Det är ett första steg, men andra modem behöver också testas. Har ni ett, testa det gärna! Vet ni någon bekant som har ett, fråga om ni får testa det med en LiveCD eller något liknande.

Viktigast är, tycker jag, att se om det fungerar i någon av de "stora" distributionerna. Fungerar det där så bör det gå att få det att fungera även i mindre och kanske krångligare distributioner. Ett annat steg kan vara att samla information från nätet.

Kan eller vill ni inte ändra i Wikin så skicka ett privat meddelande till mig eller skriv i den här tråden så fixar jag det.

Uppdatering:
Är det någon som har information om Telenors 3G-modem? De ser inte ut som E220-dongeln, så jag skulle gärna vilja veta om det är något annat märke eller modell.

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

pluns bild

De flesta distarna har NM 0.7 paket ute och jag kan INTE se någon anledning att strula med betor från Vodaphone eller andra konstiga ihopkok.

Bättre att få ordning på NM0.7

Ubuntu

http://ubuntuforums.org/showthread.php?t=797059

Om

http://www.darrenalbers.net/blog/?p=9

Gnome

http://live.gnome.org/NetworkManager

.

Så igen...jag kan inte se någon anledning till att böka på med en massa knepiga "home brewed" lösningar som inkluderar tex Vodaphones mjukvara (iofs öppen) när NM 0.7 fixar det här.

Behövs bara några svenska ägare av "puckar" som får "häcken ur vagnen" och gör en howto.

 

---------------

Theos song

FoHs bild

Ok, betor från Vodafone är ajaj, men andra betor går bra? Jag tänker inte rekommendera någon att ersätta en central komponent i sin distribution med en SVN Snapshot. Beta3:an är statisk och beprövad. NM 0.7 ska naturligtvis finns med bland programmen på Wiki-sidan. Personligen tänker jag inte lägga dit det om jag inte testat det själv,men du får gärna göra det.

Kristians bild

Jag brukar använda checkinstall för att bygga "quick and dirty" paket ifrån cvs/svn/git/bzr (osv. osv.) -repon. Funkar paketet så är det bara att köra på, om inte så avinstallerar man det och är tillbaka på ruta ett utan att ha en massa skräpfiler liggandes i systemmapparna (som man annars lätt får via källkodsbyggen där makefilen saknar uninstall-val).

 

 

---------------------------------------

 

FoHs bild

Vad är checkinstall? Det jag är ute efter är att en installation av NM0.7 inte på något sätt ska krocka med NM0.6.x och inte skada distributionen i övrigt. Dist-upgrade och sådant måste ju fungera när det är dags för det. Kan man vara säker på att SVN-versionen ersätts med den "riktiga" etc?

mikaeljs bild


Plun... du sitter nog fast mest med häcken i vagnen då du förväntar dig att nån annan skall skriva en howto...



~~~ :rs/d/u/l ~~~

 



 



~~~ Have a goodyear - http://www.youtube.com/watch?v=tO2wb-LarfU ~~~

 

pluns bild

Nej jag drar inte på mig någon puck utan kör "the noble art" via Wvdial > blutooth  och min mobil.

"Övernördiskt"....Flört

99:-/månaden....

Däremot finns det ju dom som äger en puck och kan en del och de ska för tusan klara att testa några paket...  endera så fryser man paketen för Sverige via någons FTP eller via Ubuntu så blir det troligen stabilt om jag känner "asac" rätt...

.

Några har väl koll på distarna därute.... ?????  Har själv kört NM O.7/Ubuntu sedan i Juni....det  bara funkar....

 

---------------

Theos song

FoHs bild

Svårt att skriva howto på hårdvara som man inte äger Tongue

pluns bild

Mer fakta...

Gnome/Fedora blog....  testa...!!!

http://blogs.gnome.org/dcbw/2008/07/20/the-road-to-networkmanager-07/

.

OpenSuse, vet ej om det här är sista  paketet, har inte koll på Suses repo

http://www.novell.com/products/linuxpackages/opensuse11/networkmanager-d...

---------------

Theos song

FoHs bild

Med andra ord kommer NM0.7 vara standard i nästa openSUSE, nästa Fedora och nästa Ubuntu. Nyckelordet är "nästa" Tongue

https://blueprints.launchpad.net/ubuntu/+spec/3g-networking-intrepid

pluns bild

Jo men är det bättre att köra mjukvara från Vodaphone plus x pillrande  ????.... är ju enbart stolligt..

Funkar NM 0.7 så naturligvist väljer man det för enklaste lösning men det behövs ju testande av några....Cool

.

Svenska Foresights wiki

http://foresightlinux.se/wiki/index.php?title=Mobilt_bredband

---------------

Theos song

FoHs bild

Jag håller inte med. NM0.7 må vara enklare att använda, men när den ersätter en annan, central komponent så tycker jag det är bättre att ta en "tredjepartslösning" utifall det skulle bli problem. Det ska inte vara så mycket pillande med Vodafones program.

pluns bild

Menar du att det är bättre att ta någons blog med en länk till en betaversion av Vodaphones program....???

Är ju ett skämt just nu.

.

Är väl knappast utvecklande för Gnome och oss själva.

Precis som Williams skriver i bloggen så bedömer man det som stabilt, jag har sett VPN strul men det spelar ju mindre roll.

---------------

Theos song

FoHs bild

Någons blogg? Vad snackar du om? Jag förstår inte vad problemet är. Du verkar tro att det är något litet obskyrt program som dök upp i går.

http://en.wikipedia.org/wiki/Betavine
http://en.wikipedia.org/wiki/Vodafone_Mobile_Connect_Card_driver_for_Linux

Det är inget fel på mjukvaran. Det är en beta3 från i maj. Hade det varit några stora buggar så hade det nog fixats vid det här laget.

Jag tror säkert att NM0.7 är i ett stabilt stadium. Risken som jag ser det är att installera det utan följdproblem. Jag vet inte vad kristian pratar om, men jag ska ta reda på det Smile Har du ett idiotsäkert sätt att få in NM0.7 utan att det blir problem vid eventuell uppdatering till 8.10 osv så får du mer än gärna beskriva det i Wikin. Jag vet helt enkelt inte.

pluns bild

Nej inget annat än det som gäller för all öppen mjukvara att det finns en community som testar dito och meddelar ev fel till en utvecklare.

.

Det behövs då några som vet hur man hanterar en handfull paket i olika distar.  Själv har jag 2 burkar med Intrepid och äger ingen puck, kan iofs låna en men måste då installera om Hardy...

.

Sen skriver dessa en "howto".....  så funkar det iaf överallt förutom i Sverige verkar det som...Obestämd

 

---------------

Theos song

ein.anderssons bild

HP HS2300 även kallat Sierra 8775 (inbyggt 3g modem i laptopen) fungerar utmärkt i de distar som har kärna 2.6.25 eller nyare. (fungerar i ubuntu 8.04 som kör kärna 2.6.24 också fast med lite konstiga terminal komandon)

-
Linuxportalen.se mitt hem, mitt liv, min värld.

Denna text får användas enligt CCommons BY-ND 2.5 med undantag från att den inte får kopieras, sändas eller distribueras utan att informera mig

FoHs bild

Kanon! Lagt till det på Wikin. Glad

FoHs bild

Är det någon som vet om de grafiska "framändarna" för pppd fungerar med 3G-modem? Tänker på t.ex. gnome-ppp. Skulle gärna vilja att någon testade.

kppp har jag testat och det fungerade.

synt4xs bild

Jag testade gnome-ppp på Ubuntu 8.04 64bit med min styvfars Tele2 3G-modem och det funkade efter lite krångel.

Det man bör göra är att stänga av pin-koden för det fungerar inte alltid så bra. Även om man skickar rätt kod så säger den ibland att den är fel, och när det är fel så försöker den igen direkt och tillslut har du låst ditt kort och måste ta fram PUK-koden för att låsa upp den igen. Hände mig två ggr. Sen stängde jag av PIN-koden och då funkade det direkt.

Såhär ser mina inställningar ut:

http://synt4x.ath.cx/pictures/gnome-ppp.png

FoHs bild

Härligt! Lägger nog till på Wikin att man kanske bör stänga av PIN-koden för det programmet. Säkrast så. (Edit: Det stod visst redan Tongue)

Är det ett vanligt Huawei E220-modem?

Tack för informationen!

synt4xs bild

Japp det är ett Huawei E220 modem.

http://agaton.sax.myopenid.com/s bild

Annan bra guide som bör funka med alla operatörer
http://ubuntu-bossieman.blogspot.com/2007/10/huawei-e220-med-abonnemang-...

 

Ang (telefon)nummer *99# så är det samma som *99***1#. Byta ut siffran är att ange vilken av inställningarna (i mobilen) som ska användas.
Jag vet bara hur man får fram det i SonyEricsson mobiler, gå till inställningar-> kommunikation-> datakommunikation-> datakonton, markera ett konto (du ska använda) och välj mer, sen kontoinformation. Där finns "Externt ID" och på min wap/gprs är det 3. Så jag skulle behöva *99***3# för att koppla min telefon som modem till datorn. För de som har olika simkort i mobilen med tillhörande inställningar är det nyttig info men för de flesta räcker det med *99#. Modemen borde/ska ha inställningarna på plats ett, annars blir det bara krångligt och lättheten försvinner och "normala" användare får problem.

Angående användarnamn/lösenord på Tele2 så behövs det inte längre, det behövdes tidigare. Äldre inställningar/guider har kvar informationen, troligen för att det är för jobbigt att gå igenom alla guider när det funkar ändå.

Har inte testat Vodaphone-programmet själv men vad jag läst så kräver det användarnamn och lösenord, spelar ingen roll vad du anger men du måste ange något. Kan vara fixat i nyare versioner.

FoHs bild

Det där med telefonnummer kan vara bra att veta. Ska försöka få med det någonstans. För dessa dongle:ar som följer med så är det nog inte aktuellt med några andra nummer, men kan vara bra att ha informationen på sidan även för de med mobiltelefoner.

Tack nille! Lägger nog till information om kppp och gnome-ppp.

FoHs bild

Jag har två funderingar:

När jag själv testat programmen så har jag använt mig av min vanliga GSM-telefon. Hur är det med 3G-modem och telefoner, får man ut 3G-hastigheten med wvdial och gnome-ppp och dylikt? Någon som varit på bredbandskollen och testat?

Varje gång jag fått en uppkoppling med min GSM-telefon så har jag testat med ping-kommandot. Även aMSN fungerar. Vad som däremot inte fungerar är Firefox 3. Varför? Den verkar inte hitta att det kommit ett nytt interface att surfa på.

pluns bild

Wvdial kör jag själv med via min 3G mobil.

3s billigaste abb 99:-/månaden > 300 kbits för jämnan

(inget för toktankaren)

Bra stabilt o billigt för den som bara vill ha en uppkoppling

.

Blutooth stöd kommer i NM 0.7.1 alt .5 om man kör Wvdial.

.

Puckägare/Ubuntu har nu en officiell förfrågan om att testa.

https://lists.ubuntu.com/archives/ubuntu-devel-announce/2008-August/0004...

 

Testresultat:

https://wiki.ubuntu.com/NetworkManager/Hardware/3G

.

Sen kan vi ju i sann svensk "Jantelagsanda" välja vilka lösningar vi vill....Tungan ute

 

 

---------------

Theos song

Jag tror Telenor använder Option Globesurfer icon2.

Jag har frågat en kompis som har en sån och ska få låna den så jag får testa den sen.

Jag skriver här när jag har fått testa den om ingen annan hinner före.

Enligt vad jag har hört så ska den ha stöd i kernel från 2.6.2x

Det finns en rutin för äldre kärnor.

http://www.pharscape.org/component/option,com_forum/Itemid,68/page,viewt...

http://www.mobilabredband.se/forum/viewtopic.php?id=38

Om du inte har libusb så får du lägga in den för att det ska fungera.

http://libusb.sourceforge.net/download.html

FoHs bild

Härligt!
Vad tycker du, behöver vi dela upp wikin i 2.6.2x och pre2.6.2x? Vad finns det för distributioner som det kan vara aktuellt att ha sådan information för? Det torde väl åtminstone vara ett minskande problem?

Nej man delar inte upp för sådant utan gör en anteckning om vad som gäller för tidigare kärnor ev. en länk där informationen står om det är mycket information.

FoHs bild

Lägger till en kolumn i tabellen. Vet dock inte när två av modemen fick stöd i Linux. Går det att kolla upp det på någon sida?

På sätt och vis tycker jag det är ett försvinnande problem. Kör man inte med en modern, större distribution så undrar jag om man inte har lite koll på vad som krävs själv. Vet inte om det nån större idé att försöka samla instruktioner för äldre kärnor. Om förfarandet är snarlikt oavsett distribution och modem så bör vi väl lägga till något kanske, men samtidigt är det säkert förvirrande för nybörjare det här med kärnversioner.

Kör man med en äldre kärna så saknar man stöd för mycket.

Om man använder en gammal kärna så antar jag att det är ett medvetet val.

Det räcker oftast att skriva att du kan få problem att uppnå en fungerande lösning med en äldre kärna eller nått sånt.

I linux så brukar man inte installera drivrutiner utan man kompilerar om kärnan eller uppdaterar den.

Så jag tror det räcker med en varnings text på sidan.

Men en lägsta version hade varit bra med tiden då nyare kärnor blir gamla och varningstexten ljuger.

FoHs bild

Jo, du har rätt. Var lite så jag resonerade om kärnversion också, att det är ett medvetet val. Vet hur som helst ingen distribution som har en äldre kärnversion och där 3G är viktigt för dagligt användande. Ska lägga till en liten textsnutt om kärnversioner senare.

andys bild

Jag vill tipsa om umtsmon

http://umtsmon.sourceforge.net/

Man kan ändra slå av och på pinkod, se signalstyrka.

Skicka sms tex.

FoHs bild

Tack andy! Ska ta mig en titt på programmet senare och skriva något om det i Wikin Smile

hericssos bild

Hej,

Jag har telenor 3g usb dongel. Jag kör fedora 9 förtillfället. Se utdrag från /var/log/messages:

Oct  8 15:37:33 datorn kernel: usb 5-2: USB disconnect, address 3
Oct  8 15:37:44 datorn kernel: usb 5-2: new full speed USB device using uhci_hcd and address 4
Oct  8 15:37:44 datorn kernel: usb 5-2: configuration #1 chosen from 1 choice
Oct  8 15:37:44 datorn kernel: scsi5 : SCSI emulation for USB Mass Storage devices
Oct  8 15:37:44 datorn kernel: usb 5-2: New USB device found, idVendor=0af0, idProduct=6971
Oct  8 15:37:44 datorn kernel: usb 5-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Oct  8 15:37:44 datorn kernel: usb 5-2: Product: Globetrotter HSDPA Modem 
Oct  8 15:37:44 datorn kernel: usb 5-2: Manufacturer: Option N.V.
Oct  8 15:37:44 datorn kernel: usb 5-2: SerialNumber: Serial Number
Oct  8 15:37:49 datorn kernel: scsi 5:0:0:0: CD-ROM            ZCOPTION HSDPA Modem      3.00 PQ: 0 ANSI: 2
Oct  8 15:37:49 datorn kernel: sr0: scsi-1 drive
Oct  8 15:37:49 datorn kernel: sr 5:0:0:0: Attached scsi generic sg2 type 5

/H

FoHs bild

Problemet med dessa nya modem är att de agerar som typ ett USB-minne utöver modem. Se den här sidan: http://wiki.linuxportalen.se/index.php/3G

Tycker först du ska testa med Vodaphone Mobile Connect, och därefter USB_ModeSwitch om det inte fungerar.